wine/dlls/wow64/wow64.spec
Alexandre Julliard 334f54c255 ntdll: Call Wow64PrepareForException directly from KiUserExceptionDispatcher.
This requires moving the stack switch to Wow64PrepareForException.

Based on a patch by Paul Gofman.
2023-11-30 23:12:43 +01:00

29 lines
1.1 KiB
Python

@ stub Wow64AllocThreadHeap
@ stub Wow64AllocateHeap
@ stdcall Wow64AllocateTemp(long)
@ stdcall Wow64ApcRoutine(long long long ptr)
@ stub Wow64CheckIfNXEnabled
@ stub Wow64EmulateAtlThunk
@ stub Wow64FreeHeap
@ stub Wow64FreeThreadHeap
@ stub Wow64GetWow64ImageOption
@ stub Wow64IsControlFlowGuardEnforced
@ stub Wow64IsStackExtentsCheckEnforced
@ stdcall Wow64KiUserCallbackDispatcher(long ptr long ptr ptr)
@ stdcall Wow64LdrpInitialize(ptr)
@ stub Wow64LogPrint
@ stub Wow64NotifyUnsimulateComplete
@ stdcall Wow64PassExceptionToGuest(ptr)
@ stub Wow64PrepareForDebuggerAttach
@ stdcall -norelay Wow64PrepareForException(ptr ptr)
@ stdcall Wow64ProcessPendingCrossProcessItems()
@ stdcall Wow64RaiseException(long ptr)
@ stub Wow64ShallowThunkAllocObjectAttributes32TO64_FNC
@ stub Wow64ShallowThunkAllocSecurityQualityOfService32TO64_FNC
@ stub Wow64ShallowThunkSIZE_T32TO64
@ stub Wow64ShallowThunkSIZE_T64TO32
@ stub Wow64SuspendLocalThread
@ stdcall -norelay Wow64SystemServiceEx(long ptr)
@ stub Wow64ValidateUserCallTarget
@ stub Wow64ValidateUserCallTargetFilter