1
0
mirror of https://github.com/SerenityOS/serenity synced 2024-07-01 10:39:22 +00:00
serenity/Toolchain/default.nix
Kristoffer Ellersgaard Koch aa3e13b707 nix-shell: Disable gcc hardening to be able to build toolchain
Currently, if building under `nix-shell Toolchain`, serenityOS'
gcc won't build because of hardening options added in nix,
more specifically the breaking format-security.
2024-05-14 13:57:25 -06:00

32 lines
463 B
Nix

{ pkgs ? import <nixpkgs> { } }: with pkgs;
mkShell.override { stdenv = gcc13Stdenv; } {
packages = [
ccache
cmake
curl
e2fsprogs
fuse2fs
gcc13
gmp
# To create port launcher icons
imagemagick
libmpc
mpfr
ninja
patch
pkg-config
rsync
texinfo
unzip
# To build the GRUB disk image
grub2
libxcrypt
openssl
parted
qemu
python3
];
hardeningDisable = [ "format" ];
}