navinstall/PKGBUILD
JMARyA d6042bc2e1
All checks were successful
ci/woodpecker/push/build Pipeline was successful
update deps
2024-12-27 09:46:49 +01:00

39 lines
874 B
Bash

# Maintainer: JMARyA <jmarya@hydrar.de>
pkgname=navinstall
pkgver=main
pkgrel=1
pkgdesc="navOS Installer"
arch=('x86_64')
url="https://git.hydrar.de/navos/navinstall"
license=("MIT")
depends=("arch-install-scripts" "archiso" "sbctl" "sbsigntools" "git")
makedepends=("rustup" "git")
source=("${pkgname}::git+https://git.hydrar.de/navos/navinstall.git")
sha256sums=("SKIP")
pkgver() {
cd "$srcdir/$pkgname"
echo "$(date +%Y.%m.%d)_$(git rev-parse --short HEAD)"
}
prepare() {
cd "$srcdir/$pkgname"
rustup default nightly
cargo fetch
}
build() {
cd "$srcdir/$pkgname"
cargo build --release
}
check() {
cd "$srcdir/$pkgname"
cargo test --release
}
package() {
cd "$srcdir/$pkgname"
install -Dm755 "target/release/navinstall" "$pkgdir/usr/bin/navinstall"
install -Dm644 installs/* -t "$pkgdir/usr/share/$pkgname/installs/"
}